Search This Blog

Thursday, November 18, 2010

VMWare View 4.5 Fix for Windows 7 provisioing error: "View Composer agent initialization state error (18): Failed to join the domain"

The same thing happened for Windows XP, but that fix is different and I already posted that solution previously.:)

View Composer linked clones fail to finish customizing when they are created from a Windows 7 parent virtual machine and the Active Directory is configured on Windows Server 2008.


Most linked clones that have this problem cannot join the domain. View Administrator displays the following error message: "View Composer agent initialization state error (18): Failed to join the domain (waited nnn seconds)."

This issue does not occur when the View deployment uses an Active Directory instance that runs on Windows Server 2003.


1. Take the following actions in the Windows 7 operating system on the parent virtual machine:
*  Set the default DHCP gateway. In the Internet Protocol Version 4 (TCP/IPv4) Properties dialog box, select "Obtain an IP address automatically," click Advanced, click ADD under the Default Gateways list, and type the default DHCP gateway.
* Disable Internet Protocol version 6 (IPv6).
* Follow the instructions in the Microsoft Support Knowledge Base article, Unable to Join Windows Server 2008 R2 or Windows 7 Computer to Active Directory Domain.

In particular, add the following Windows registry key to the parent virtual machine:

Value Name: NeutralizeNT4Emulator
Value Type: REG_DWORD
Value Data: 0x1

* In the DNS tab of the Advanced TCP/IP Settings dialog box, remove extraneous DNS servers from the list of DNS server addresses.
2. Take a snapshot of the parent virtual machine and create the linked-clone desktop pool again.

No comments:

Post a Comment